Character Limit - Attachments

Our process: We have an import watcher service looking for emails that come into an Inbox. We bring in the body of the email AND the attachment that's attached to the email. We OCR both the email and attachment.

Issue: In only one instance have we seen this, but the email body was pulled into OCR while the attachment was left off.

How we Fixed it: I changed the name of the attachment to a shorter name - it was 70 characters and I changed it to 64. The next time we tried to import the email with the attachment, it worked.

Question: Is there a character limit on attachment names? This PDF name had special characters, but I did not remove any to make it work so I would guess it's not a special character issue.

Answers

  • jclarkjclark Posts: 43 ✭✭✭
    Could you give us the full path filename of the attachment?
    Grooper should be accepting the Microsoft Windows standard of 255 characters for the length for an import file path name but that would include the full path not just the attachment name.

  • rmcentirermcentire Posts: 37
    In my testing:

    This worked: C:\Users\rmcentire\AppData\Local\Microsoft\Windows\INetCache\Content.Outlook\GR4S3YS8\AURTHUR GALLAGHER NAME CHANGE.pdf - Workers Compensation Renewal.pdf
    Character Count: 154

    This did not: C:\Users\rmcentire\AppData\Local\Microsoft\Windows\INetCache\Content.Outlook\GR4S3YS8\AURTHUR J. GALLAGHER Invoice3268385.pdf - Workers Compensation Renewal.pdf
    Character Count: 160

    That's the path when I open the PDF from the email. If it's on my desktop, the file path is even shorter (C:\Users\rmcentire\Desktop).
  • jclarkjclark Posts: 43 ✭✭✭
    Can you try re-importing with the original filename to confirm that it replicates the issue?
  • rmcentirermcentire Posts: 37
    We successfully replicated the issue with that document 3 different times. After modifying the name a few different ways (drastically changing the name, removing 6 characters, etc.), we successfully brought the PDF into Grooper. @jclark
  • jclarkjclark Posts: 43 ✭✭✭
    @rmcentire I have not been able to reproduce the issue today on my local Grooper. Which version of Grooper are you on? This way I can test on that version to see if this is an issue that was resolved with a newer version of Grooper.
  • rmcentirermcentire Posts: 37
    @jclark 2.72.0026
  • rmcentirermcentire Posts: 37
    @jclark - Hello again.

    More testing:
    PDF name: 90 characters
    Full filepath name: 170 characters (with spaces)



    The email pulled in, but not the attachment (would be page 2):

  • jclarkjclark Posts: 43 ✭✭✭
    @rmcentire - Hello, I am still unable to replicate your import issue using your Grooper Version 2.72.0026. 
    Is there possibly a way you could email me a mock up of a PDF file that does fail to import for you?
    If so my email address is [email protected] 
Sign In or Register to comment.