Grooper 23.00.0020 is available as of 5-15-2023! Check the  Downloads Discussion  for the release notes and to get the latest version.
Grooper 21.00.0073 is available as of 5-19-2023! Check the  Downloads Discussion  for the release notes and to get the latest version.

SharePoint Online

jmcmanusjmcmanus Posts: 27 admin
edited January 2019 in The Astronauts (Q&A)
set up a connection that was working fine.  had to change my password due to security policy.   When I go into the CMIS settings I can go into authentication method and logout and log back in.   It shows that I am now authenticated, but I still get the same error message when I try to use the connection.   tells me my provided grant has expired.   How do I get it to recognize that I have logged out and back in and have a new grant?

Best Answers

  • jmcmanusjmcmanus Posts: 27 admin
    Answer ✓
    I got it figured out, after you log out and log back in.  before you expand the tree structure, you have to list the repository again.   Once I did that everything else worked fine.   Thx. 


  • jmcmanusjmcmanus Posts: 27 admin
    Just a few more notes, if I try to reset the connection, I get the same error, my grant has expired.   I did set up a entirely new connection, with this exact same settings and it worked fine.   I just can't seem to get Grooper to recognized that I have reset the password and have a new grant for the old connection. 
  • jmcmanusjmcmanus Posts: 27 admin

  • rmccutcheonrmccutcheon Posts: 756 ✭✭✭
    I have asked the dev team for help on this, to see if I can get it figured out.
  • dlittledlittle Posts: 39 ✭✭✭
    @jmcmanus you could help us on this one. We want to make sure that the login's aren't expiring. Each time you have to refresh your SharePoint OAuth login, record the date and time you refreshed it in the description property of that CMIS connection. This is what I've been doing, to see if there's a consistent lifetime for a login. If we can determine that the logins are indeed expiring, we'll make a code change to refresh them dynamically when the connection is used. We don't want to have to do that if we don't have to.
  • jmcmanusjmcmanus Posts: 27 admin
    @dlittle , I don't think you need to change the code.   What I discovered was that just going to connection settings for that CMIS connection, and expanding authentication method and logging in and out, doesn't fix the issue.  After you have done this, you just need to list repositories again, after that, the connection fuctions properly.   As long as you know to do that extra step, everything is good. 

Sign In or Register to comment.