Grooper 21.00.0082 is available as of 12-12-2023! Check the  Downloads Discussion  for the release notes and to get the latest version.
Grooper 23.00.0044 is available as of 06-20-2024! Check the Downloads Discussion for the release notes and to get the latest version.
Grooper 23.1.0022 is available as of 07-05-2024! Check the  Downloads Discussion  for the release notes and to get the latest version.

Running a Custom Activity manually when it should be unattended

Grooper 2.72.0022

For some reason, I am having to execute a Custom Object that we have been using for over a year, manually now.  This is an object that is used to communicate between Grooper and our internal system.  I have attempted to reboot the server, turn the service off and on, compile the script, update preferences, and still the service will not automatically fire.  In order to get the batch process step to execute, I am having to pause and unpause the batch, without changing, resetting, or updating the batch process step.  Does anyone have any suggestions on steps that I have not tried?  Also, has anyone experienced any issues like this in the past?


  • Options
    BrianBrian Posts: 30 ✭✭✭
    edited September 2021
    @JWoodring I have a few questions that may help you or allow us to facilitate better:
    1. Once you pause/resume the batch, does the service pick it up properly or must you click Process for the task to complete?
    2. Have any other changes (i.e. environmental, updates, virus/malware software) occurred that coincide with this issue appearing?
    3. Does the issue result in exceptions logged/written to Grooper's event log or the Windows event log?
    4. Is this issue intermittent, or does it occur 100% of the time for batches containing your custom activity?
    5. (Obligatory question) Has anyone revised the custom activity code or the process(es) containing the custom step?
    Brian Godwin
    Solutions Manager
  • Options
    [Deleted User][Deleted User] Posts: 0 ✭✭
    I apologize.  I was able to resolve the issue.  In an attempt to increase processing speed, services had been turned on our scanning pc's that run the x86 version of Grooper.   I removed all of those services and the batch process step is firing off automatically.  Thank you.
Sign In or Register to comment.