Grooper 21.00.0082 is available as of 12-12-2023! Check the  Downloads Discussion  for the release notes and to get the latest version.
Grooper 23.1.0021 is available as of 06-14-2024! Check the  Downloads Discussion  for the release notes and to get the latest version.
Grooper 23.00.0044 is available as of 06-20-2024! Check the Downloads Discussion for the release notes and to get the latest version.
Options

Having issues with render.

We have issues getting render to consistently work on the same set of files.   All are word or xls.   We change things in the environments and sometimes they will render and other times not.  But we can't figure out an patterns as to why.   Most recently error message is below.  We have tried setting up separate local accounts to use to run the service render is logging in as.   

'Render' Error: Unresolved dialog. A dialog box was detected in WINWORD, and no Dialog Response Data Type has been specified. Dialog content: #32770 Microsoft Word Word couldn't start last time. Safe mode could help you troubleshoot the problem, but some features might not be available in this mode. Do you want to start in safe mode? [Yes] [No] 

We can see that this is telling us that a dialog box is opening when Grooper is trying to render the document.  what we can't figure out is why this happens one time and not the next when rendering the same document in the same process.  
Tagged:

Answers

  • Options
    rmccutcheonrmccutcheon Posts: 756 ✭✭✭
    Are the documents somewhere that I can get to them? I will test them if so. 
  • Options
    jmcmanusjmcmanus Posts: 27 admin
    I've been doing some testing, and I am only having issues using the files that I demo and process over and over.   I've tried several batches of files from onedrive that Grooper has never seen before, and I get no errors.  I have a theory that Grooper is changing an attribute or flag within the file itself and that is what is causing the rendor errors.   
  • Options
    jmcmanusjmcmanus Posts: 27 admin
    I took the files that render was having issues with.  I opened them and saved them as a different version of word.   if they were .doc, i saved them as .docx and vice versa.   I ran the files again, and they rendered properly.   But in the past, the original files worked fine.  I believe that when you process the same files over and over again, something is getting corrupt or flagged in the files that is causing the render issue.  For now I have decided to keep a clean copy of the files in a folder that won't ever get processed, and when I have issues with render, I can delete the files Grooper is processing and replace them with the clean files.   Hopefully this fixes my issues with my demo processes that have been failing. 
  • Options
    GrooperGuruGrooperGuru Posts: 481 admin
    The error message here is stating that when the Render Printer is opening the file behind the scenes in its native application, a dialog box is coming up and you haven't configured Grooper to handle that popup box, which prevents rendering from completing. I'm guessing that you have found a way passed the issue by simply having opened word and manually clicked through the dialog once.
    Matt Harrison
    Product Manager
    mharrison@bisok.com
  • Options
    jmcmanusjmcmanus Posts: 27 admin
    that's what  we thought, but we can open the file manually and don't get any popup boxes, and we have tried it the local user account render runs under and with my domain account.   my theory is when grooper processes the same file over and over again, it gets corrupt or something is flagged in it.   I fixed the issue by deleting the files and copying back in the originals.   I think this issue would only apply to demo labs, I don't see production environments processing the same files 100's of times. 
Sign In or Register to comment.